Create a Rails 4.0 beta application


Create a Rails 4.0 beta application



Rails 4.0 is not a stable version yet and there is not official gem available so you must set it to get it from the master branch.
Rails 4.0 require ruby 1.9.3

Clone rails


  git clone https://github.com/rails/rails.git



Now let's install Rails dependencies


  cd rails
  bundle



You will probably get


  Bundler could not find compatible versions for gem "bundler":
    In Gemfile:
      rails (>= 0) ruby depends on
        bundler (< 2.0, >= 1.2.2) ruby

    Current Bundler version:
      bundler (1.1.4)

  This Gemfile requires a different version of Bundler.
  Perhaps you need to update Bundler by running `gem install bundler`?



If you do, you would must run


    gem install bundler --pre
    bundle



Now we are ready to create a rails 4 application
Must specify --edge (master branch)


  railties/bin/rails new NEW_APP_PATH --edge



Now you have your Rails 4.0 beta app ready
Enjoy it!

References


By Pablo Monfort



How to contact us

Our Location

DireccionArismendi 1420 Of. 102 Telefono(+598) 2409 15 66 Mailinfo@vairix.com

Follow us


Want to contact us?